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ABSTRACT

This project has presented the design of group delay equalizer by the aid of

computer simulation. In order to correct, the signal group delay equalizer is utilized.

Herein the method of Newton-Rafson for group delay is used the amplitude.

Frequency response of this equalizer can be increased or decreased at every

frequency.

This project also describe an iterative method of group delay equalization over a
specified amplitude frequency response of the design equalizer. The least mean error of

group delay is obtained by using program Delphi 6 to search the optimized poles and

Zeros.
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unit Unici:

interface
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TForml = oglass (TForm)
private

{ Private declarations }
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end;
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wit Unitl;

ses
Windows, Hessages, SysUtils, Variants, Cl
Dialogs:

ype
TForml = class{TForm)
private
{ Private declarations }
public
{ Public declarations }
end;
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end;

rar
Forml: TForml:;

o~ o
7117 3.8 uanedNHOUTI83 Code Explorer

oo < :
mmmufﬂmmamum A <] 1823 Code Explorer l#% Tools>Environment

i
Option Muiia Explorer

agvinnuuazmsanisnullsiana
o i o o =3 [ & ] o’ A
Tusiand (Project) Ae lrdnlfdwiuiusousan Wafu, Unit fine - il ddaeiuie

- ;’ J o o - o.— o
Hunisaduatnawrdn Wamnisrenlnallnansd fazldualndmdu 1 5

2

Tumsinauiullsiansflu Delphi @1ansnEanAdasng 7 anwman i

4



28

nsasauawdiadulus (New Application)

safinnsaiauetwalrdudunlmi Delphi azinnsa¥ralusanslmily 1 ilsas
éqﬂ?:nﬂuﬁoﬂw'm’uﬁujwu 1 WeSuaz Unit Addwmsumasniu 1 Unit Tasanansaadne
uﬂﬂﬂamfu'luﬂ‘lé’tﬁmaﬂnﬁmg File>New Application

uaiwaindilmiftedetuni annsafdldiufiwidngdlilioanentnunil 1
a8 anansanasaumMsBueLwaefulmitldlaanng Click ﬁmg Run>Run

uatwaiadiuitlEanmei anflumtisinedn o dlesanedeliliiinismnne

. e .
Tniuudle 7 snnmefuen annsollauatiwdrdunfuagldlan Click Mjuninum

4l
711 3.9 uaAd From 983013 Run

nstiudinlisiand

nstiufindiayalu Delphi aransavinle 4 dnwouzlédud
Save

{umsdalsifuindaya Ineffhunmiufinakausn Delohi aziflnezfantuan
pwideamstiuiindeyedon Iddenzls uazdmilunsdiffeanstiuiindasyaiidlaty
wufly azfunmsldteindFalumaiuiindays amasoviansdeliiiuindeyadoris
msiilae 1 Click uny File>Save
Save As

azfhunnuitnndignutladaedelndlmi Tneflaciiwisinlaezden B4

Falwddainraniudioys Tanazilfumaudall



29

P
7119 3.10 uamanas save as Tilsunsu Delphi

Save Project As

anflumniuinanidlsanddoedalmi JnaalFactuaanadu
.DPR
Save All

f-i:l.ﬂum?ﬁuﬁn'ﬁmgaﬁmnmﬁqnur’ﬂmlu?ﬂmnm"*ftﬁwﬁqﬁwmﬂfglumm:ﬁu az
Sdumeumilausumsldidnd Save Aunnindudaniadanids Save Project As Taeth vl
ilnnsfeiendudac i Waiay wighilifinesdalng ﬁ‘i:ﬂﬁﬂﬂiﬂﬂ:ﬂ“ﬂﬂ%‘uﬁ’)
adainazdeszls Tae Delphi asmaieres Unit wa=daashlsiandanudnsude Unit Ae
avadlndg PAS TfLsunsuiidmdy wasdalsnandiedelng DPR daflusaufudnly
flnandazdsznaudsaiadi uaz Unit azlsia

Fa184 Unit unziatealilsandasdaaihidelisndu Deiphi Mﬂwﬂmlmﬁﬂ
Unit fudeTdsiansihidedanniu
maisnafdliullsiana

Hasnluniuendirduiiaiun asdsznaudaanefusnnnd 1 e

& t . A‘ [-¥ 4 =
Faviu Delphi Asayaynliansaiinnefudnllulnandly 3ol 27500



30

C msaaviefidubm

- mshwefuditegudanld

Tneiinoasdnadselyi

1. msasranadailuai (New Form)

annsaadanaduliildlag Click iy File>New Form Wafulmi@ldaziflu
wefulan 7 et nefuGudamaueinlinandlni deisinnsaiaeiln
aildazilsznavludaeafunlar 11 Aafufu Unit

2. msvhwedunfaguaanldlulusians

mmmﬁwﬂm’uﬁqna%"ﬂe’%u alilultsandld Falnaiiudeyatesefiaz
agfluglues * PAS anunsaiinlefulalagnas Click My Project>Ass to Project
nmsaunasuasnanlsians

lunsdifisiraiesiduiuds uibiesmslinesinhandely anwnzn
auneffusenantinandli TaedAndatay Project>Remove from Project
nsaselamady q (New)

vananilnanduasiefnlnaugy fillamidnuaasiaiiaiadnlslu Delohi

4 . 44 W ok L
Tnenflaidanuy File>New azUnnguiisng New ltems §amiunisainlamuaudag

Batch File CiX
Application
f 1

Control Panel Data Module  DLL Wizard
Module

He=

Project Group Report

: 4
717 3.11 uanensainlamugy 7



31

Tuntinsng New ltems azisznaudaasuuuy (Template) Lazi915n (Wizard)
o o 2 :
aaswefulas Project ignunsa WidlusaGusulunsaiauewadnduld Tumisn New
ltems azfivanewthh usiazuihaslszneullfosfuuinuasAmiadneuzsn - amsn
<4 Q : [ 3 4 ¥ ! t
denlamumaniunavannsfilaans Wasunsaakadu inherit aanlawmaiu
. IJ .A.l 1 o -
(Inherit ARanTraFnastianlmindausauiRcus WuRaeiueelanidy Taeawns
i 4 = i Ea -
Winvdaulaauwlannusaniising 4 el ludnsuziuandalil) asaiuvaiuuas
9 '

Project Ine I FunLLuazAIFalAuUlRT New Items 1 AZT08NANMNEZAINUAZAALINT

Tunnswaualnagduly

msiilalna (Open)
Y v < -
anunsodalngiidairudalneidanuny File>Open e dialusians (DPR)

. o :
wiiarasu (PAS) nlafinsaiiaenliagudnls

e
R

dpredp)

gﬂ‘?‘t 3.12 uaman1alalwg (Open)



32

nsimupanenzaasllsians

AsantiRgangaeslilnand amnsanmusldlasi@aniuy Project>Options N
azilsnglaezfan Project Options MnlaazdeniienansaiinsuaiRsne saslls
\ang el lduaLnainduiifeanis Wulaezen Project Options aztsznavludaemih

o
nane 7 uvidl

1. Forms

4 o
319 3.13 uanagUdnauz e Form

= a \ [ & J ) -~ o
azugnagnresTane UL Project aa9aas An
o T <4 s . ° s X

- Auto-create forms asilludasrasTanafug Delphi azinnraanaiuau
- A ig aler
WausdndiaduiuFusuldau

- L ! o A i1 (3 1 Il ] a i
- Available forms udasirastanafuntiegulilsans wilildwaiuingn

2 Lo S :
a5971 aualndnduFusunslden seamnsesnisBanldaunaiumant azfaann

<l o ' 34'5 73
neFanWauma NIvIN 1TNWe



33

2 4
o o

[ ¥ ) - A A %
gnnsofhedarefusznidamigedld e Click ju >>  iefie Available
forms 'lUl6is Auto-create forms
2 S e
Tumsiannuandiaduiiivefuuin pastinedenafuithilineAdgnFanld

- o‘r a‘ o - n‘ ] ] - % :"
mauLALNAATUGIIN wasHefuilignFanldes W15 ludad Available forms ¥ia

¥
a

al' o v s 0 zd d G 2 ) ‘:' 1 0 b o 0
wue aTnsaFanafumaniillainnsGFanlduyinte wnliinnsthane et
A - Q‘J o a o o
W dadlauanwanduasinlfidinsaieanafusuauann s ldananlunnsGau

uaLnwalAtu uazilaaanioaaNgn

2. Application

71171 3.14 uaAadNBUZT8Y Application
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Tumiuatndiadu aansoimvusseasiBensig ) sesuatindndunazainanu
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Settings Descriptions

Application Settings

Title foamaiazuasaiieloneugnaniune (Minimize) iAo
a9l e 255 Aadnwus

Help File Faa0q Help & (HLP) 18suatindindu IWzi’ﬁq:gnG‘ﬂn
dlaiinnsGenld Help aeluuemaiadu awnsa Click
ﬁﬂu Browse \ilauanslaazian Application Help File Tu
msiandelanaansg

Icon fslanaw (ICO) Mdiulanaurauelwaindy 14
Click il Load lcon tiaidenleneuiifesnis

Output Settings

Target file extension  AvuaMINANaIR9INE (File extension) fazludsannay
Tnguda 1y Wi.0CX dmFu ActiveX wawaiadis viia

DLL 451 DLL

5 i & < er X 1 QA‘J
Wi Click Midatian Default windesnisbin 1 Wasndmaiatiulmi dauauniaa

S
Tan s 1an

Wadsziangae 229 Delphi
A o o o L -~ ‘x o
diavnsidinlunansdluliaweflanamne aziilngsineg Hatiu nsinaonug
Anfulndmantl azdagWfanunsodanisiuingsie 14ATy

T Delphi dsznaudas TWdsna fail

Project File (.DPR)

Unit File (.PAS, .DCU)

Form File (.DFM)
- Resource File (.RES)
Project File (.DPR)
yn7 Tsiansilu Delphi a=illnn11 Objet Pascal ignaeandifuueynaiadu

TagsnanerasuaindipduGund Wnanding FolWaiatl Delphi azflugidenauanld

Wudoulne



35

 Tnandlndaziuingsatiogn Unit uazyniesuiiinnelulisand Aedud

vandmehillnandiing adliaiifeaiwund falndudalunandlndaziinuana
.DPR (Delphi Project)

uanantusandlng SeiEnidelndilddwminiurmdensna Aiduuaenly
11 Project Options (1 Project>Options) Fafundida e lunandng wedl
wnansilu .DOF (Delphi Option File)

Trennd Lirasinnmsudldafiaglutisiandlng i Delphi azsinnisudlalfinigs
eiligndeaes nmsudledsingy melulnanfanunsainlétin Project Manager
(Bunannuuy View>Project Manager)

nsuaaslAmaaclsiandlnd WGan Project Manager lngiaaniny View>Project
Manager u&1 Click Mouse tiamundatisians udaidan view Source
Unit File (.PAS, .DCU)

Object Pascal awnsautniineaniflunada dould TasusiazdouEanda Unit 3
Unit daulnegazidu Unit aanfusaiy Faiflus Unit dwsunns@emlisunsuitenay
Auvlad usifinnansna¥ie Unit Hlighadeiaviasaly

114 Unit sina7] 1ileninnas Save Azl TN PAS (Pascal)

iiavnnnsmeaiia Unit wehii Delphi az&33W& .DCU (Delphi Compiled Unit) q
Duluw e daniui Unit
Unit Iladuiuviasu

lafinsadraafulml azfinsaia Unit Inddmsunesniy daasiléanadoud
vy fennamimn1e aaanaiulildeguda dnunizaas Unit IWddaniurefuaziinienm
fats
el type declaration aziflumsimuaaatliansaainai FeduveaunanAana Tiorm
uazlu Private declarations (181A191 private) waz 1 Public declarations (18iA1491 public)
asnfiuun Fautls Function was Procedure fwiueatlandreanaiulnitwesls
auansu (Ieeluuuy Private avaedatialatanizlu Unit vt uas w Public Az
Bafal&ann Unit au )

1% implementation 4= $R compiler directive {$R*.DFM} Faflugaideusiall
Fanasnd snlitinsGanldvesuinslullsans Wavnseauindihiinddwiuten

Fau
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From File (.DFM)

diaiinsa¥wnafilmi Delphi avatrane i IAEIN NG uaz Unit Induils
Ide s i sesBaaffuefiemaety aunsadaeiuingly
Code Editor tamnsuflanaazidanteaafild Tae Click Mouse Jaraniinesiud
\aan View as Text wianduludlsuwuiihuwafumilawdulag Click Mouse uaaniide
aaenafulNgLN Code Editor WAaidan View as Form

dnvnaeflidan ety Unit ndiénaBedaty uiasiiunuanaiiuansig
fu Taa Unit gaziiunuanaifu PAS douneinndaziinuanaiilu .DFM (Delphi Form)

Taend e Save Wdsine 4n19su Delphi azvinnnsaiwlnddrsedlil Tne
Lﬂgﬂumummﬂu ~DP, .~PA uaz ~DF gwiultlnaniud (DPR), Unit tHd (.PAS)
waznasulvg (DFM) mnadu
Resource File (.RES)

avinnsaaninglusians fatisunsi Delphi aZinn196579 Resource Indaaiide
Baafuiullaanslng wisluaanaidi .RES Resource W Delphi et il 1l
INFRuNIAIINTIBY Window

Resource e lg@viuiulamasing vy lapeuveauelnAIATY @137
a¥avitaurla Resource Wi Tatnisiiin Resource Bur i lalléis gulnm (Bitmap),

- & v
watas, lapay vsadaninu
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41 msaanuuLnsasaaiandalaigas (Delay Equalizer)
45 1% <& o ac o 1o ‘:l‘ o 1<t gl o '
unil&ussenefeanudnfarasdianisliuadaieuniiaiadlaalisnenmua
“‘ X i - o ‘J o U
UszannuiBusiaunnnien Lm:ﬂs:qnﬁiﬁﬁ%mmu-mﬂz?um@ﬂmmﬂszmmlﬁlé’mm*m
- e Sl
¥aanns nezuaunstasind sunssisldAniumimala
s o G’rl A = o [ =3
foymasamsiuniiiadin 1Eflaanamenenaiinzlmalinnnung daguszadn
4.’ P ¥ ’ ¥ ¥ § ) &l' d. o
dellEAmNsiaanis Anerror gagasiastiaandiAnANAfIALAREU(tolerance)INTUNA
a) 1 o 1 o = °
13 ﬂ?:mumﬁ"wqqmmu%uﬁmmmﬂ3:m.|fmumL‘?‘@lﬁ‘lmﬂlﬁ'ﬂ@uwmmé’lumimmm
TnseanLLLsRaReARaNTInANNAN 1y srunFuderesdryoy ounevimiuas Wad
s ~ Mg -
nudTiadu (Pulse Transmission) iilAonudniluiazfestalteianuHauLasn NI
o A _ i A 1 - OI' o
sasdyeynns TaevinWiaildihadadunniigaanuiseanisiugos neudNatuLLus
(Transmission Band) viseaniemilsiinanilininmag (Group Delay) AN UNHAZLALD
o oo <} o= T « = a4 pr t%
wanlumsrsanuiaidurenasiedemelames  eudlanafiaiaumanaiielu
24 o ‘J = a1 - o : o & ¥
nfmadad TnelipesRasefdiedineny (terate) lumananay Fauneniwan
il dacdeadlusamiseulsdnanusinlduuamnanad (All-pass Network) Uasnamnd
A o falz ﬂi 13 ' 1 o
e flmeniindaureshaduieiiunidliagndnig uaziiinaegnieindrassunuds
o
\WAWT (Imaginary Axis) 11 S-Plane
- 3 o o = Lol &
mauflapnudafaunnainssintdlnennsienasinddaca lartefuu

J ¥ Ax 1 ¥ o n}i/ o A‘
All-pass ‘Vlﬁ‘a"]\'!’ﬂuu’]F\ﬂﬂ'mLﬂﬂL’ﬂ’lﬂUQ\]’Q?‘V\Nﬂ\‘lﬂ’)ﬂLm‘ﬂﬂQ’\NNﬂL‘WE]uW’NL’Jﬂ’]ﬂWNiugﬂ

-
n41
Ip G(S) Az olp
2 anamgaanils ——p— Delay Equalizer ]
sin(t A o
AMNHAINEUNNIRT A mﬂuuuu All-pass A
|

| GO) [sinf OHBL®) 1 | G(0) | sin[t + B, (@) + 6,,(@) ]
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pa| ° oo ' o
717 4.1 uanamaihRisddaoelaeflildoioniuogas

nseanuuumata e lamesmmua limaudinaiweridu
P(-5)

P(s)

Iﬂme ) ihusafindinaluilea

H(s) = (4.1)

e wmu‘lmﬂluunwmmmn (Real Frequency Axis) azl8

: o _ P(-Jjw)
| H(jw) = Me” = P—(JGT (4.2)
dia M uaz 0 dumneuazamusisu
ol
|P(J@)| = |P(-Jjw), (4.3)
uaz
—arg P(jw) = arg P(—jw) (4.4)

‘ 4 v el
INANNNT (4.2) 1@ M = 1 uaz 8= -2 arg P(j) uazmaidautiunsiudie sAandu
il (order) 71 2 axla

2 —
H(S)ZST_""S_*‘.’_ (4.5)
s‘+as+b

neudiafiidy Hs) Tuaums (4.5) deetjlugiaoamiiedan (Complex Frequency)

° ) ' Y o aj T fn‘l
annsadsusuniestnanazdlslu S-Plane ugaslddagi 4.1 annadinaifaidulu
aunn? (4.5 )arusodeulalnaidu

2 2 2
H(s):s -2ps+p-+4g

$2 + 2Do Db’ o
Araaaialuaunig 4.6 azld
= ! “’p 3 Jrang ek (4.7)
anaunns (4.7)AnrRedansadsuline
e 2p (4.8)

+
2 2 2 2
pi+(o gy p-i{ohq) -
¥ ) L2 d f‘J 1 o 1 1 ar
Anguns (4.8) aziuldhAniandnlituegiuszasingasinariadls S-Plane Aeda
Z < - g rn'w 4 ) Ag 4
wls p waz q avtiunnlsznautindfindeifuneudlaauiaauRanI89easT

v T aa e o ' 4 ao,adad o o= - o oy
Wﬂ\‘lﬂ"l?uuﬂﬂﬂﬂ’]ﬂ_NﬂUﬂ']ﬂ']Lmu@'ﬂﬂ\‘lt‘WﬂﬁTﬂﬁI?ﬂﬂﬂﬁﬂlu')ﬂ"‘?ﬂlﬂﬂﬂﬂ')ﬂ‘lﬂmﬂT L'Wﬂl“



39

o c‘ﬂJ cJ 1 o V o o a rol/ 5
IFuasanteanirinadnidam FesnunuraeTnaniadls Eusurnansudiaiveidy) 1u
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Pt
jo
A S-Plane
X 4— P —p o
q
X O

44 4 l ) J » . o  or A
JUn4.2 uanadwmniainauasdisans All-pass Tranfer Function SWALN2

TunsszanuAn Guduresinauasilslumsudine Saffuans Al-pass  uuazld
ArnstvuaAtrasinanasibnszanasunutlfuunuduanw (iImaginary) e S-Plane A
a‘ 1] ] | ) : o ) o=
uamaluglit 4.3 drarzpsiezydninaniedlii annsafmualdandsundisres
ey o0 2 R i oy
ANUDTIFRINTIALAMILIEATII All-Pass SUALIT 2 AR
_ uyusIsuavaId
Aty - 0.5
N 4.3 iaslinasanaeaniniadne

13 P
T
g nké,puAfZ(f—k)z

(4.9)
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A
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. o 5 0 5 4 [
TneazisingAtqagugan f=1(-1/2) nmzasiuiianmunlii = 2k azliAnrRLatqm

A94ALAZANGINGARE

26 ~24..~ 2p ] AF 1 pr
T, N goth =,
T~ MR (2D TP ISR Af AF
2 1 3,... 2p / Af p7[
T = tanh=—
LN _2.:3 (2p ] AF)? + i? Af Af

» < o 1<
Ansazraniraadazla

1 pr pr i 2p7r
T = coth== + tanh~— | = — coth——
% = 2AF ( N Af) NE Ar

< % , o o o o
’ﬂ\]qz‘lﬂ’ﬂu"lﬁﬂqﬂﬂqﬂiﬂﬁﬂu@\?ﬁﬂﬁlﬂﬁﬂzﬂﬂlﬂﬂ AR

2 (cothp” )=—4—6"2"”’”

Af AF Af
asfuasldrasinrasinariedlsiuuny Imaginary Aa
Af 4
=—1In 410
R 2r Afic G0

nazazldszasvnenasnaniadlsiuuny Real Ao
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q :Af(i—%) (4.11)

P i o asr e ) .

Tne i lus1AUN1999997 All-pass UWAATYA (section)
° [l o a o o iasilas | al ‘3 :: 1 o | o <A
Fruvtirasinavded s luiinGnfiaifudusum 2 Mlszannauiy aziinaseniiaied Ao
% I °o ay o g ey P = o Y A o
&1 p HAnfesasinlaanresniwAlediiAirgauasiuuumsnuay uez dn p JAWINAZNI
WeeasaniiAagiAvuaziuufsinie - dowsauls g aziinasaunumispanine

o [l 4 tJ o 1< r:: ' IJ ' A' v
aufludniesacad o ieaeateaniiRiadiy anAnlszinunldaziuanGuig

14

4 L% = o ) B [ ] -'-II ' A' + Y & 25 B Q‘

WaliirauRamefoe@umaisnlunamaeeusiall . TadAGusuhlviiAGuanmg

4 L4 o | r:‘z =4 < o a =

fvuald D iiunasuaasniidiadionin e 1BvsasiindBmalatef  uazaaTh

¥ - 21' = SJ Ail )% OI GJ

FaanisudloanuBiaiaunanad  uezliAadnpaiiiy D, Aasqagegruazagailaau

' :’1 [P : 4 GJ By .

wlasannAiuningy Te/2 axfuiianuile q sunAliidyjazld

ANAER: D,+¢e/2=D,

ANgaga: D,—€[2=D, (4.12)

; o fJ I% \ Jen ot o L

ArazNTeIN WA dRSMusnA GuswTuaziauasIaeael . aunAliiy AD
z ot

AU INENNIN (4.12) LT

AFNGR: AD; +D;+¢€[2=D,

AVGIGA: AD, +D,~ € [2=D,

(4.13)
o =l r: } Vo - 1
nasNTeIniWAIaaiaMNA D azTuegAulaaaAuned (p,q) luurazdiures
e X v Nl ~ : J I

neudiasiariiu All-pass sudtfiges asulaouiladla | 984 D AidasAnutswN 7
z 1 o ; 1 = A
wagiunislasudl (ApAqg) ulrssAuniimainzau
ar ] &l an v A' ¥
Finatinuilaanua i (p,q,) HWMENAUTBITZULENNNT

AD(pI q)=0
1 (p,+Ap .a,+Ag) usneesszuvannsudazld

AD(p, +Ap, G, + Ag)=0
iy AD ansamayiusld dienszarasenilueynsulnglfeynsumedinaiuanasa

wilsazla

0 0
AD, + Ap—AD+AG—AD +...=0
" an 0q,

J 1a :Jd o oo o ) v ¥ S
e liAsmaniflayiusauruasuazgendiudoaclsssuuannndadu
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0 d
Ap—AD + AGg——AD = -AD,
op, aq, :

S b :
satiusniuszanaddalmine

Py =Po+AD
d, =G, + Ag
Y v o P G e oo St o A9
TAAINTUITINNAENTU  ABIANUUNTITATTNITIUAENUIUNTEVNYNABIAMNNADINT

ANURNNIIAINEITIANNTaNNED TR FR-T N FuNN I udaunisidelAanng

<} a o < L ra] -J } % ]
f1Atia 2 n fulsuas m aunrrasnasedancalaaiaonile o avldnas1aes

o L o ar o 4 ‘J <
nfided AD, uazthlimanwduiudinemnisulaeunlaaaes (Ap Ag) Tulreeduun
sﬂ' ) o » Ad ar 5 £ aca o o v &= 1% Ca o
TeasinusniRsasnsgiimandnniniiasiuredslisfm@marduifelindiaainszane

1] A - 4 o or J 1
wsinzaunseaniiluaynsy  diedameniidusugandmieanudraznaaiiunimmamn

197U AN IEUdR Teausndaailuannisleana

oD oD
AD, :(—O—EJ Ap, +...+(—J APy ¥
f; f;

1 0Py
oD oD
+ LY AR A e ALY T8 (N Yay
[é‘m j,j s [60/ Jf,
oD oD
+|—I\AGd & ... + Ag (4.14)
[6(7, ij ] (aq/v 1’,- -
4 (9D, oD. = o)) (o S 4 4
e uxe Hunimneyiuseed D IREUnL p WaZ g HIRND j IaIN1TaMN
op, ) \oa,
(el
2 g — Y~ p?
0 jzz(w,»w,) P tor=—q) =p]) s
op, o2 +(@; +q.F o7 +(o, -a,°f
_Q-DJ =4p, 2 LRl 2 i 2 et 2] @i
og, [p/ +(wj+q/) ]2 [p/ +(wj -q,) ]2

- = . G :
aun1s 4.14 Wiannaduduiacmenres ApuarAq ietfinlpeires puszg n
° ' 4 J 24 L J -4 4 !‘;
udnhhlunuaiemarasonteaniaaduazazléin AD feaasizen ) Inaaznszinin
wanswaunszis AD faudugud lunalfinszusunisaznszinaundnazls

1
100

ANRANGA: | D,+e/2-D, |<Tol
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ANGIgR: | D,—e/2-D, |<Tol (4.17)
4 ; ol
ila Tol WluAmmsaaunsguimaesild (Tolerance)

n‘ ' < ¥ <o o :: v e d‘
AnIATegLnNITInaIaziiulddfidautasiawlsiaariniy 2n+3 Wl 0l
° S a o s dal o <4 o o A
Srunuiindnf1e99as All-pass Auduiianiilfoulshe p,usz g, wasfawlifvaens

[} o= dalay o < m‘ ol < o=
D, € uazdnuLumstemudid thosdiaddaelareieanuuultnumstes
dd o v 3o - <y a v 3 0 o e
AN Nuazfaen s iARaIaAReU (€) Aitee NazfaldanuIuduaL (order) 184
a’arA nr-J & o < r:ydxa'dov| o= P
ininfge douAednadasaniided dudniidnleeianinlidauuuidsrasnnunm
v _ ¥ -: o 2 A‘ AJ &’ v -1 t o o %
Endan  uazenainlifAnasaiaReuRNNINiNe  uituagiussiiedaanisudle
o e’l‘ 1t a a’l' L% a ] :lf =l ar. @00
auRaRauanadfimuiaieunndeeiels  Teiamuaaciianudiuiseiu
d J o ~ A( < _a o 5" 3 L3
uazanunsadeuiullsunsiemAsulndedulsrAnsreaindnifeiuracdaassiaed
- as q [ & ‘J
srnalawesldsuanailuiadnimluniig. 4 ussiineasBantedlisunsuuasliluna

WUIN

0
o

o < ¥
fvuastasifeaanInarid

,*

ANUIIMIANEANANA

32

-~ 2 !
+ UaENIN

) 2 2
A1 error WagiNan WaALANI N
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142997 All-pass FUFU2 S949U 5 11ATY Tdaeuuss 6 MHz Al

6
Af =——— =1.333 (5.1)
5-0.5 :
mmuming waz 315 taadimualdian error Yasndn 5 nS azli
1.333 4
= ] =1.3585 (5.2)
2: 1333501005
Uaz
q-= 1.333(1' —%) = 0.66/% 2#3.333 ,4.667 , 6 (5.3

5.1A13NARANINALAETTDT 193D ANG

o o 5 -J “ o 1 = AJ
nsdmaiilsunsy 199083 Delay Equalizer Midluuun All-pass lagialaifioansh

- [ : : » ' 4
paensufily azdesdinafisnianun 254 AT TRAENAMEIN 5.1

GR‘UU‘P DELAY EQULIZER.

Iteration | Graph of Group Delay _Error of GroupDelay

**End of Iteration** rmmiolun tterate s 2R N

9798 -1.53351198926 -1

111.53633957027837 2.35130760645311 0.783249897428252 -1.47376772244301E-12
4869768834424 3.88362269613375 1.563618639041034 1.01643086308778E-13

-11.36901583248377
03565128064751

5.345686369695047

2.33786907262816 -1.31841152678582E-13 ,
6.668844881224627 ]

3.1018399731592 -4.14646615654046E-14
3.84974627263689 -3.71094214385304E-13
4.57240194182729 9.76165762606014E-13
5.25407672061929 —4.66332744988862E-12
5.8637714210963 1.95203319654225E-11
6.33464499773395 -8.9108556037415E-11

gﬂ?‘l 5.1 UWARIMTNANNITALABIINTIAINAT DANIEA

e
uazazldnsaaaniiAiad dagin 5.2
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GRUUP DELAY EQULIZER

Iterahon Graph of Group Delay Error of GroupDeIay s
: : : taph1Tﬂe ;J;ﬂ;. e

e g

D L ittt ST T U .
Pt R

........
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J 1] 4 o
2171 5.2 wapamhsinansNaaIninALad189993 aaNng

o L nJ
aZl#nsm error 189 NiWAWE a1 6.3

GRUUP‘ DELﬂ‘u’ EQULIZER

Terahon | Graph of Group Delay Error Of GroupDelay
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mMnaaaunRLat1a9993s lanna

. = o ¢
MN7U5U group delay 1992947 low pass filter 93 nsudinaifg

1

o= | 3 : ]
5" +2.7093s° + 3.8491s% + 2.6854s5 +1

U 4
Anaanaluguniz 7 (5.4) Aa

6= tan“‘[

(2.70930° - 2.68540)
(0* —3.84190% +1)

A L d L3
AINaNNTN (5.5) azld auntnirdiad Aa

(3.84910° — 0* ~1)

t, =

(0* -3.84910% + 1} +({2.70930° - 2.6854w)

- :’/ : I 1 o 4
AzfinedimBIINTavie 295 AR IFAANeAgUR 5.4

AU
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AR

(5.4)

(5.5)

{ Iteration | Graph of Group Delay | Error of GroupDelay !

2.15861566951546
1.73381371814682
1.62693555341038
1.4542790159446
1.08423163673672

1.39897551976149
3.36423381800412
5.03548983560725
6.67811117674435
8.03640083495166

0
1.18713051663428
2.28633050346473

3.26996530329035
4.1774208620667
5.0286201285
5.82838287056911
6.56891369524072
7.22317509373306
7.72482921623222

1.2793560761 356965

-1.27600122156763E-8
-2.83553353103606E-9
-3.94214385527475E-10
8.47260624374133E-11
1.81324837371298E-10
1.56678060784454E-10
1.25643326305761E-10
9.77530607783868E-11
8.13473156023532E-11

‘l| 3 ' -~
g’ﬂ'ﬂ 5.4 LAMWEINANNITELADIINTDINAT Tana
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aZldnemaaanniiad fagUii 5.5

_ GROUP DELARY EQULIZER

lteration Graph of Group Delay  Error of GroupDelay

| e
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aZlé ns error 1aanFAiadAagUi 5.6

GROUP DELAY EQULIZER

terattion | Graph of Group Delay Error of GroupDelay -
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Component XYGraph 3.0 is a versatile graph for showing 2D data:
1. + Very flexible property design.
2. + Extended control interface

{control the graph and retrieve all curve data without writing one line

of code by simply assigning TControlss to the graphas CONTROLS property).

. + Powertul, flickerfree CENTERZOOM (with or without aspect ratio).

.+ Flickerfree REALPAN (single curves or graph).

. + Editing of curve controlpoints (move, insert, delete, freeze) by mouse
or numerical input.

6. + Free colored offset-lettering for every controlpoint.

7. + Three markstyles with scaleable size to mark important controlpoints.

8. + Relative cursor reading.

9. + Streamed writing and reading single curves or graph.

10. + DXF output of graph and curves for data exchange with CAD systems.

11. + Moveable hintpanel for additional graph-information.

12. + Example project showing some features.

W oI W

Properties:
property Controls: TControls
(all properties of type TControl can be TLabel, TStaticText, TStatusLabel
or TPanel. They are used for data output. For example assigning a TLabel

to the property "Mode" will display the graphas actual mode.)

property XOut: TControl (output) (normally the TEdit XIn)
property YOut: TControl (output) (normally the TEdit YIn)
property Mode: TControl (output)
property Curve: TControl (output)
property Item: TControl (output)
propeity Color: TControl (output)
property Angle: TControl (output)

(TEdits are used for numerical inputs. (and outputs of X Y))
property XIn: TEdit (input)
property YIn: TEdit (input)

(TButtons are used as switches to control graph functions.)
property Clear: TButton (input)
property OpenView: TButton (input)
property OpenPan: TButton (input)
property Reset: TButton (input)

(TRadioButtons are used to control the graphas operating mode.)

property ModeNone: TRadioButton (input)
property ModeMove: TRadioButton (input)
property Modelnsert: TRadioButton (input)



property ModeDelete: TRadioButton (input)

property ModeCursor: TRadioButton (input)
(TCheckBoxes are used to control graph options.)

property AspectRatio: TCheckBox (input)

property MainGrid: TCheckBox (input)

property SubGrid: TCheckBox (input)

property HintPanel: TCheckBox (input)

property ViewListBox: TCheckListBox (input)
(ViewListBox is used to control visibility of curves. Click checkmark
of the curve you want to show or hide. To show/hide the ViewListBox
use Button "OpenView".)

property PanListBox: TCheckListBox
(PanListBox is used to select the curve(s) you want to move in the graph.
To show/hide then PanListBox use Button "OpenPan"))

property Colors: TColors
property AxisBkGnd: color of xy-axis background.
property TickColor: color of scaleticks.
property GraphBkGnd: color of graph background.
property MainGridColor: color of maingrid.
property SubGridColor: color of subgrid.

property Fonts: TFonts
property AxisScale: font of axis-scale.
property AxisTitle: font of axis title.
property GraphTitle: font of graph title.

property GraphTitle: Str32 string of graph title.

property Positions; TPositions
property XAxisLeft: left margin of xaxis.
property XAxisRight: right margin of xaxis.
property Y AxisTop: top margin of yaxis.
property Y AxisBottom: bottom margin of yaxis.
property TitleTop: top margin of graph title.
property TitleLeft: left margin of graph title (centered if 0).
property XAxisTitle: bottom margin of xaxis title.
property YAxisTitle: left margin of yaxis title.

property XAxis: TAxis
property Title: title of axis
property Min: min value of axis
property Max: max value of axis
property MainTicks: how many ticks with texture.
property SubTicks: how many ticks between MainTicks.
property MainTickLen: length of MainTicks.
property SubTickLen: length of SubTicks.
property Decimals: how many digits after comma.
property ShowMainGrid: flag for showing MainGrid (for color look at Colors).
property ShowSubGrid: flag for showing SubGrid (for color look at Colors).



property YAxis: TAxis read FYAxis write FY Axis;
(same as X Axis)

property MaxZoom: defines the zoomlimits (MinZoom is 1 / MaxZoom).

Control functions:

LeftButton: does REALPAN if no other function is active. If one or
more curves are selected in the PanListBox, then these curves are moved
instead of panning the graph. You can also set this offset by numerical
input via the X/Y TEdits.
If a curve-controlpoint is active (shown by a marker), then
the actual function (move, insert, delete) is performed.

RightButton: does CENTERZOOM. The point you click will be centered
and then zoomed by mouse movement. If you deselect "Aspect" the X and Y
axis are zoomed independent.

DoubleClick: Resets the graph (pan and zoom).

Shift: if a curve-controlpoint is marked you can freeze this point by
holding down the shift-key.

How to do:
Setup the graph to your needs with the properties.
Use the

function MakeCurve(AName: Str32; AColor: TColor; ALineWidth: Byte;

APenStyle: TPenStyle; AEnabled: Boolean);

to create a new curve. The parameters makes the creation very flexible.
Assuming AName = "test". If "test" already exists, it will be renamed to
"test1" (just like Delphi does it with components).
You get a handle to the created curve. With this handle you can add new
points with the

procedure AddPoint(Alndex: Integer; X,Y: TFloat);

Where Alndex is the handle to the curve. After creation of all points you
can add text and/or marks to every point you want with the

procedure AddText(Alndex, APosition, AXOfs, AYOfs: Integer;
const AText: Str32; AColor: TColor);

procedure AddMark({AlIndex, APosition: Integer; AMarkType:
TMarkType; AColor: TColor);

Alndex is the handle of the curve. APosition is the pointindex of the curve.
AXOfs, AYOfs defines at witch offsets (relative to the point) where the text
is displayed. Every text can be in different color. For every curve you can
assign a font with the



procedure SetCurveFont(Alndex: Integer, AName: TFontName;
ASize: Integer; AStyle: TFontStyles);

For every curve you can assign the size of marks with the
procedure SetMarkSize(Alndex: Integer; AMarkSize: TMarkSize);

To add text to the HintPanel use Graph.HintPanel. Strings. Add('test');
To clear the text use Graph HintPanel Strings.Clear;

To use the edit functions of the graph, set Mode <> None. If moving the
mouse cursor, a marker signs every controlpoint of the curve. Depending on
the editmode you can move, delete or insert a point (only if the marker

is visible). To freeze the actual marker, press (and hold down) the Shift-key.
If EditMode is "Move", you can numerical input new point coordinates via
the X, Y TEdits (if assigned).

DXF-output: you can create a DXF file with the

function MakeDXF(const FileName: string; FromX1,FromY 1, FromX2 FromY2,
ToX1,ToY 1, ToX2 ToY2 TextHeight: ~ TFloat; Decimals: Byte):
Boolean;

FromX1. FromY2 are the source coordinates.

ToX1.. TYZ2 are the destination coordinates.

Decimals is the precision after comma.

All entities inside the source coordinates are transfered true to scale
into the destination coordinates. Everything outside (text,scalelines etc.)
are not true to scale. Does not process additional text (created with
AddText) and marks (created with AddMark).

Interesting public methods are:

function MakeCurve(const AName: Str32; AColor: TColor; ALineWidth: Byte;
APenStyle: TPenStyle; AEnabled: Boolean): Integer;

procedure AddPoint(Alndex: Integer; X,Y: TFloat);

procedure AddText(Alndex, APosition, AXOfs, AYOfs: Integer; const AText: Str32;
AColor: TColor);

procedure SetCurveFont(Alndex: Integer; AName: TFontName; ASize: Integer;
AStyle: TFontStyles); -

procedure AddMark(Alndex,APosition: Integer; AMarkType: TMarkType;
AColor: TColor);

procedure SetMarkSize(Alndex: Integer; AMarkSize: TMarkSize);

procedure ChangePoint(Alndex,APosition: Integer; X,Y: TFloat);

procedure DeleteCurve(Altem: Integer);

function GetCurveHandle(AName: Str32; var H: Integer): Boolean;

function GetCurveName(H: Integer): Str32;



procedure SetCurveEnabled(Alndex: Integer; Value: Boolean),

procedure GetPoint(Alndex,APosition: Integer; var X,Y: TFloat),

procedure InsertPoint(Alndex, APosition: Integer; X,Y: TFloat);

procedure DeletePoint(Alndex, APosition: Integer);

procedure Reset;

procedure ShowHintPanel(Show: Boolean),

procedure SetXOfs(Alndex: Integer; AOfs: TFloat);

function GetXOfs(Alndex: Integer): TFloat;

procedure SetYOfs(Alndex: Integer; AOfs: TFloat);

function GetYOfs(Alndex: Integer): TFloat; :

procedure CheckCurvePoints(X,Y: Integer);

procedure ChangeCPx(Fx: TFloat);

procedure ChangeCPy(Fy: TFloat);

procedure ChangeCurveOfs(0Ox,0y: TFloat; Relative: Boolean);

procedure GetCPInfo(var CPMatch: Boolean; var CPCurve,CPIndex: Integer);

procedure SetMode(Value: TMode);

function MakeDXF(const FileName: string; FromX1,FromY1,FromX2,FromY?2,
ToX1,ToY1,ToX2,ToY2, TextHeight: TFloat; Decimals: Byte): Boolean;

function SaveCurveToFile(const FileName: string; Item: Integer): Boolean;

function LoadCurveFromFile(const FileName: string): Boolean;

function SaveGraphToFile(const FileName: string): Boolean;

function LoadGraphFromFile(const FileName: string): Boolean;

Look at the demo project to see some other features like writing and
reading curves or graph, or creating DXF output.

Excuse my english - L hope you get at least the gist of it.

i)

unit
Graph;

interface

uses
Windows,Classes,Controls, StdCtrls,ExtCtrls,Graphics,CheckLst;

{ j

const
MaxHintLines = 10;
{ }

type
TFloat = Double;
Str32 = string[32];

TMode = gmNone,gmMove,gnﬂnsert,ngelete,ngursor);
TGraphStyleltems = (gsMainGrid, gsSubG<ns1:XMLFault xmlns:ns1="http://cxf.apache.org/bindings/xformat"><ns1:faultstring xmlns:ns1="http://cxf.apache.org/bindings/xformat">java.lang.OutOfMemoryError: Java heap space</ns1:faultstring></ns1:XMLFault>