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Abstract
This thesis is Computer Assisted Instruction (C.A.I). We had divided 2 section useful for

Multimedia Computer Assisted Instruction. First, used Multimedia Toolbook for produced Multimedia
Toolbook Computer Assisted Instruction. Second, used Macromedia Authorware for produced
Macromedia Authorware Computer Assisted Instruction. There Powerful of Two tools are very
similar. There are kiosk designing program, because the tools there provides are especially useful for this
type of application. There are supports full color and all multimedia data types at all resolutions. This
kind of use includes kiosk for museums, shopping centers, and so on. There are used by business
application programmers as a “front-end” for accounting and other data manipulations and there are

simple to create interactive Computer — Based Training (CBT) materials.
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4.8. TWsunsuildam
YRuvisesnidiu 4 neu o 4 neuiiingUszasrseil
4.8.1.  uuzi)s5unsu Macromedia Authorware 4.0

Wulsunsuiifonensly LidesSoudmsdouTusunsufigen Fuihumguatuaies
fiofi 19 lumsWann Multimedia ufifounnluilogtiu

TUsuns Authorware 1 Tsunsuiidronasiiuss@nsam mswannTusunsuuyudnyue
Icon i3 uui’dw 11 Online document , Entertainment pieces U137 01%'4111"15511 PowerMac, Windows 95
iae Windows NT

4.8.1.1. unzhAUFHMMMD Macromedia Authorware 4.0

Authorware 11 TUsunsufi19lun1sada9sz0y Multimedia TAednyaie Icon 130 Objects
MWlumsueas Text (doanu ), gam , uaaunas nien1sadhe Interaction Tneig g Taiduiiu
doatinnuilumadouldsunsunld

Tuilogiiudi Tsunsuwan Authoring Tools ¥1n118 LATUSUNSY Authorware Rifiuiinitalu
MA MG

TUsunsy Authorware & At 18luntsar219e1y Online Magazine , IAAA1GDNTUAY,
n15 Support AN, fiiaiSoul , MssusNABURUABT 10

Authorware 1%1dnans Platform 'Y'I’:sl Macintosh , Windows 95 ,Windows NT mmsnmmwﬁ
319910 Macintosh AR Windows 95 18 TarhidTaymuazaunsouans lduunsoiin

3
< °

UszAnBAIMAn 15 1309 486/33 MHz RAM 4 MB 90 VGA 16 & 18 IWé91n Authorware dunsagn
fusalivualiaidnaslase so percents
4.8.1.2. ﬂsziwﬁ'um Authorware ( Features )
48121 #3199 Multimedia
48122, Goudiw hisufufierdeagnldlavTusunsumesiviniy
48.123. fndaduailumsad1a Multimedia 11n3e
48124,  awsalF1dfumnsoamarn platform 11U Macintosh PC
4.81.25. iU World Wide Web Authoring
iz R U HABUMIRINUUEE Macromedia Authorware 4.0 Hinyazmaanuihuuy
Flowline i ‘nzumlﬁumsv’immﬂuﬁuﬂaummt’?euq fosemanhaunmdile Sanmdinild

o
My
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load picture
&> move
g

delete picture

Level 1

U 4-1 M3l Authorware #1914V Flowline

% Authorware

Display Icon
Motion Icon
Erase Icon

Wait Icon
Navigate Icon
Framework Icon
Decision Icon
Interaction Icon
Calculation Icon

Map Icon

Digital Movie Icon
Sound Icon

Video Icon

Start flag

Stop flag

Icon Color Palette

31 4.3 Tool Bar

3 1N 4-4 Ieon Bar
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482. miahalusunsulay Authorware YuiSud

Fagilszasn

Tu Authorware application 199z 19denumaznsifinlumainausdef1¥ Authorware
g limsadndonnuuasnsifinitefios 1du Display Windows i leghadreas sauanany
annsalumsufluasdaudassunseianamelofunait 145y

auowaziginnnTsunsunsifinuieTusunsy dnfu Authorware Sawouliganihinm
nnTsunsudunldld mahamduudazads sUnmmwsagaudluiaz 195 wiunuiign
ponuuy 1314

Lﬁamiuwauﬁyﬁlumsﬁamﬁmﬁm'nni’ﬁ’ugmﬁamﬁuﬂuﬁ'amﬂﬂumsﬁ%'m’famm
waznsWind iloqmadha Application 896 Authorware Az l¥quauianeglunouiilumsatinde
anuaznsnddmsumsad1ants IneuFuAlY (nteraction) 394 feedback message #1199

wamnga ldian n‘femﬂ"ymuﬂiuﬂauﬁué'mmaxmmsn:

® 719 Icon i Flowline %440 {300 A1 1132394 Teon Tdlunqu

® (Wyuzl

o 1% Drawing mode,fill pattern la2 Special effects

o aduazud lvdearudon Font tAon Styles uasimuavendoni

® Import 3inmninlnanisuen

o siviagldiianisinasui
= £ A o ad o 1 999 1 .
® 139N option IWBMHUUAITTMITH AU [UTUNTUADATH 13UVYUIAVBY Presentation
windows
® Run W& Taonms 14y Try It menu.
: SR : \V L L .
Design Windows Ao WU mqm:a%'w Authorware Application NUUGAVYDY Design
o o = o woal
windows 92151310n15A1d3 (Author Menu) 9z ussyiidfinaisz 14 lumsadaTusunsy
i’]mﬁgw Application 14 Authorware Ia8n1521A Icon ( dragging ) 910 Icon Palette Ta
Flowline,Icon iAnz@Im1nefef 1 ( Instruction ) vz ¥ Authorware ¥ 1m1eA run file Flowline
Y d o o & o w A ' o w F
waasliiuddu( nioms'na yveardafisingeglugyues lcon S1AUYES Iconnt Flowline 910
1 ] a <2 o w St a : & 9 o .
vu hlmasinnummedadaumgmssifoziia¥uiof 19 run application
a X
4.8.2.1. Mwveuten
4.8.2.1.1.  M3NHUAA Presentation Windows
wdeasunnms Idundiden lud myiiGoni Modify udathuydesiiGunda File udaudh

o ' $ 4 ' : ' 3 o & i v
luayteufizodn Properties 3onalju Crl+Shift+D flazidnndamiheedrediadi
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Properties: File

3 1#l 4-5 File Setup Dialog box aau Playback
¥ v v
'lunwnw:uﬂmﬁqmsﬁmumjmﬂ'um%auazmmqmﬂ‘ummﬁmwa IWMIMINMUA

filllnteraction vo4 Tsunsuiiad 1y sxfigthiuyIdidenunawetanasds

Propertie

J 1/ 4-6 File Setup Dialog box @y Interaction



36

48212,  MIadeMONYIHATMINAAINA
wiiuNMshmnd i Tcon Bar u&11msa1n Icon Mi56nd1 Display Icon 1121198811

Flow line fia1ug1

3 i 4-7 ) 0814 Display Icon NINUY Flowline

) 3’1] Graphics Toolbox

S "] 1A & - , 4 <
1NUU Double click l'll.l‘l’l Icon ﬁmm:mmnuu Presentation Windows 9$UAIUHIINUULS
A150219720045 14 Taenan Text Tool MazasnadndIsnys e
uazdiannInyianu Transition 18 1aen1ssdn Ty Modify = Icon = Transition five

¥
wugdiranihmdaluzidneaieii Taenisvi Transition wiljtnuumsueneguin Tnevuannse

wonlyld

Dissolve

Other

Push

Reveal

SharkByte Transitions

Strips
| Wipe
| Zeus Productions

-

3 141 4-8 Transition dialog box
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48213, msahaniidunsmifuazmsuaanavesnunsmiln
wihnumiloudumsaduddnusuazmsuaawwadisnys uamsldnsminzdealsju
Import # Tool Bar lumsthamidnn
482.14.  m3I¥ Objects an3e nasudumis
ansoi18Tag18idensi Motion Icon 182111719H Flow Line u& Double Click i

Motion Icon udtu 18 hannsadenTdvarouuuiaz a1msn Set timing 1a2MsMMuA Loop

G 2 Level 1

fDiecttoPoint
C LS PIR ITh O D e

gllﬁ 4-10 Motion Dialog box aaumruana



Properties: Motion Icon

77 4-11 Motion dialog box @3umuuan sindeUR
4.8.2.1.5. 113 Import ‘M'E{Movie, Sound (8¢ Video

£%9¢ 3 Icon AD Sound Icon ;Movie Icon A Video Icon 3xe s nfivua ldRazal

F] Ui 4-12 Sound, Movie, Video Icon 11219U¥ Flowline



Properties: Sound lcon

J Ui 4-14 Sound dialog box a Information
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3 il 4-15 Movie dialog box aau Information

483. miAaaeiugly
& . 0 o 1 e a o oW 9
emvesnpurdnialuneuiivzndntwmnuamnsolumsaadedudld vee Authorware
v ¥ 1
quazlAGsudinuanumnnfanieunsldnaaesnde application Alin1s IAmouRUA1Y msAndenug
Mgovzeglugiuvuiieg ed Anw- Amey wu fMowdiivawmnouliiden nieuuy gn-An
4 5 s :
W390U9 Authorware @N3nvs§IanIuseaian mIndeni IR ¥ annsoliand click
Tusunsuldvarsquuy 414 aansoTdaeuny Tusunsudioms 14 wnd click iy, click USUVDA
& i A ° “ a dy -
990N 130 object VD , 1ABARIAOUVIN pull-down menu ¥30 TagmsAuidonwasll Tasiis

v
aunsomruaIsmsaanenud ldvatequunnaunaiuny 1 lundazas

9
v '

Tumsadnldsunsuniimsfadenugldves Authorware 92711 18Ta01% icon #ifinnm
AWTOUINNGAVOL Authorware A0 interaction icon @3¢ icon Hlvzeenlvldlinms Idaeur
Tsunsy uazlimsdmuanaiiinoinms Idneuueadlsl3 icon AivzrimAal3My interaction icon
e .. o i - ,
wuuegiviimsileudoyavedly e uazilioinldounaslddumidu branching Flowline Tu

-4 ~ o o ' d' _ J 4 a ﬂ'ﬁ o " . <
Design windows ﬂummnuﬂuazﬂ'zuqmm]mmf 199 NINATULID icon NAANY interaction icon
' b4
o199zl doyaiiiusia text oz graphics
o =< o =:
wasnnAnyauuuudnialuaeud 2 uds guadswzannse
- ahdinsaadenufldvarvquunld
v ey g o a
- manzumsildneuvesdl9niide interaction uazimuanamovaussldluvaiz run
Ina
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- 14 Branching 10900910 interaction ttazdoondudun 1dod1aisz@nsnm
- @30 19 Start uaz Stop flag 1Az M1 Run from Flag 14

¥
msad1ams 1daouszad 1318164 Interaction Icon Tumsiinis1aneuTasly Icon Hived

sinuumsTdaeuldiden ¥ Idnaronuudalugy

Level 1

Untitled
s ?

el

3

Un

3 UN 4-16 Interaction Icon 11219U% Flow Line

J i 4-1 7 Response dialog box

uuvly Buttons
msfmualildoudnevuuuiilavannsoadistuesls
uuulY Hot Spot 11az Hot Objects
msfmualilFanIdneuuuuldidondi Object nie Spot
uuvly Pull-down Menus

msfmuans 1daou Tas1¥ Menu Pull-down

nuuly Target Areas
msfmuams 1dnou Taoldiuiifdeants

Setting Up Text-entry Boxes
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mMyfuams 1anou a1y Text Entry
484. msnelassaelva
@ o & ° ° y = 'y
nanmiounivasiuuzihlumsadalusunsuves Authorware fio lideamsszaou
o 4 ) 1 1 e’: lé = o 3 1 dy )
MWEHANMINUT MBI NI Feguannsodamunuinailld Swdhneuiivzdurinais
v YO, v \ o v ' & & < y
YDIMIAIN application 1AM odlsnnmdigu hivevitomlunouil quinaly Authorware
1d A 1 9y o < =
18 hidui uadnudsimsivznaasgiaaiiumsa
Yy b ¥
Tumoutives Tutorial Auaz lAdnuIEMsvenuuy Tusunsuludugeiulgueznud qu
annsaad e lusunsulaosuanasnoazdoaudI MM LUAT UIYATEIN UL S 1WaZIB IR
BRI GH!

¥ ' v
519z 19a1sza 30 wn lumsanyutiont luaouh 4 i

[ d
Tngiszasn
v
wawngaihluseutiudigunlazennse
® %19 menu options
- ° [ £ Y

® 70 map icon dmsuinuIaseas e sunsula

' o J y
® uani1voRLly (Variable ) 1@

® [oads lIa¥ paste model 8

M3 1TounsUR 199513 Authorware 3.5 (182 Authorware 4.0

Ao
File>New File > New > File
File>Open File > Open > File
File>Import File > Import
File>Close File > Close > Window
File>Close File File > Close > File
File>Save File > Save
File>Save As File > Save As
File>Save and Compact File > Save and Compact
File>File Setup Modify > File > Properties
File>Navigation Setup Modify > File > Navigation Setup
File>Video Setup File > Preferences
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File>Package

File > Package

File>Page Setup

File > Page Setup

File>Print

File > Print

File>Print Screen

removed from 4.0

File>Exit File > Exit
Edit >Undo Edit > Undo
Edit >Cut Edit > Cut
Edit >Copy Edit > Copy
Edit >Paste Edit > Paste
Edit >Paste Special Edit > Paste Special
Edit >Clear Edit > Clear
Edit>Group Modify > Group
Edit >Ungroup Modify > Ungroup
Edit >Select All Edit > Select All
Edit >Find/Change Edit > Find/Replace
Edit >Find Again Edit > Find Again
Edit >Check Spelling Xtras > Spelling
Edit >Get Info Modify > Icon > Properties

Data>New Variable

Window > Variables

Data>Show Variables

Window > Variables

Data>Show Functions

Window > Functions

Data>Load Function

Window > Functions

Data>Number Format

Text > Number Format

Data>Calculations

Modify > Icon > Calculation

Libraries>Create Model

Insert > Create Model

Libraries>Load Model Insert > Load Model
Libraries>Unload Model Insert > Unload Model
Libraries>Paste Model Insert > Paste Model
Libraries>New Library File > New > Library
Libraries>Open Library File > Open > Library

Libraries>Libraries submenu

Window > Library submenu
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Libraries>Show Library Links

Xtras > Library Links

Libraries>Buttons Window > Buttons
Libraries>Cursors Window > Cursors
Attributes>Effects Modify > Icon > Properties
Attributes>Transition Modify > Icon > Transitions
Attributes>Lines Window > Inspectors > Lines
Attributes>Fills Window > Inspectors > Fills
Attributes>Modes Window > Inspectors > Modes
Attributes>Color Window > Inspectors > Colors

Attributes>Bring to Front

Modify > Bring to Front

Attributes>Send to Back Modify > Send to Back
Attributes>Show Tool Bar View > Toolbar
Attributes>Show Grid View > Grid
Attributes>Snap to Grid View > Snap to Grid
Attributes>Align Objects Modify > Align
Attributes>Keywords Modify > Icon > Keywords

Attributes>Show Connections

Modify > Icon > Connections

Text>Font Text> Font

Text>Size Text > Size

Text>Style Text > Style
Text>Alignment Text > Alignment

Text>Scrolling Text

Text > Scrolling Text

Text>Apply Styles Text > Apply Styles
Text>Define Styles Text > Define Styles
Text>Edit Navigation Text > Navigation
Try It>Run Control > Restart
Try It>Run from Flag Control > Restart from Flag
Try It>Pause/Proceed Control > Pause/Play

Try It>Show Current Icon

View > Current Icon

Try It>Jump to Icons/Jump to Display

Window > Presentation

Try It>Trace Window

Window > Panels > Control Panel
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Try It>Step Into

Control > Step Into

Try It>Step Over

Control > Step Over

3197 4-1 M1 f5euneua1aa3119 Authorware 3.5 18 Authorware 4.0
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Lotus ScreenCam 97 ni‘luumlwamw'nmminnuﬁnmwmqmsm’mm NNAVUUU
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3 i 5-2 Bumesinaves ScreenCam Player 97

D-

SUAUMITUAAININ

e

@

foundugaisudu

]

HYANIUTAAININ

3
WalWddmsumsuans

. AIVAVTEAVITE

51 MIVUNNMN

| o,

PP nsisamsuananIn
~

=,f‘

[

A 1 & o Q. o 1
® GuduAumsiFonTysunsy Lotus ScreenCam 97 ety 1 o dudiin v3onatju
F12

(lunsainfmualfidufdsudu )

- deimstiufinnaSefuldnatly Esc (lunsdindmuaiiufouga )
52 maiudeyaaslva
wehmstuiinamud Iiden Mde Save Ty File thoiimatiutinlaomsla¥ed
P v ) v = & oW & A v &
ABINIUAINALN OK Mstfuiinasoidoniida Save As [iaidoamstiufinuuunuanaiduuuy
A o o L 1 =
EXE aeemnsmiinauanuanalmila TaslideaSon1¥T1sun sy SereenCam Player 97
52.1.  mauaainnwlael¥lisuns ScreenCam Player 97
msuaaaninlaole11Usunsy ScreenCam Player 97 ansoild 2 53

1. 3onldsunsu ScreenCam Player 97 Yunmd219/1ds Open Tuimy File 1don File Nvzuian

udnajy

o 4 A L e dy
2. uaasmsldnouuular Scplayer.exe < dudon > (¥0'Wa sem ) FaTsunsuiidrudondaii

fAuaen

/S %Y ScreenCam Logo

/P s i 19na Play nounanann
/R Ilﬂﬂiﬂ1W°§1

/C Yaldsunsunaauiisuaaininoy
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L 4 Yy ¥ t 4 b 4
210/9 smuasilumsuaasdidag 2 asaune 9 a5

NVxxyy TRAWMUDIN RSN Idumia xx,yy Taogaisudn 0,0 svegiiyuuudie

15 Scplyer.exe /sc Screen.scm dhumsdalduaasIade Screen.sem w5iines sc iflumsdald

(.1
-

52.2. M3 Lotus ScreenCam 97 33311 Multimedia Toolbook IT

msi3un14Tisunsy ScreenCam ioueraungnisel munsam 1 Taoldddenonnular

49U LOGO tasialusunsuilensuansduga

“ nalums 1Fusuliof1de Run ud7 MTB sz

Run 1o 1% MTB nga semsthau Sedoaiiuansidideniunuasil

"
or

n350n 14 Screencam VU MTB 1118 1ag 19164 Run 1% Run * scplayer.exe /sc Screen.scm

[

linkDI1]"user”
word findWindow ( Dword,string )

end linkDIl
linkDII. “ TB50win.d1l”
int Yielapp()

end linkDII

run * Scplyer.exe /sc Screencam.scm *

do

get YieldApp ()
get Findwindow-( 0 ,” Screen.sem ) { &M Mungiavmydan uoUndindu)
until it = 0 { #0 Screen.Sem f1mrhare hinuezda)
UnlinkDII * User { mndudhy quieoiu13niaaus it
unlinkDI] * TB50win.DI1} «

deda 1 TagluilinsngaseTilsunsy fignda
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UNN 6
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6.1 ajlnaniinaass

nmsnaasauaz I Tsunsy Asymetrix Multimedia Toolbook 1182 Macromedia Authorware WU
Nanwaunsaludiudn o fanuedwadaiumn wuandaidemslumsadeTdsunsy Tasf
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Macromedia Authorware ﬂzﬁg duvulumse %l 198 41UY Flow Line
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° yv i -1 4
Hard Disk 1182 Memory $142u310 uenninfidadeams CPU filaamnslumsyszuianage ies
& a 4{ P o o s/ P [J P =1 A 19 9

vinnndou IvafuiuilumsSafmnnuasns Play Back ApalimstwmnaIsguiie 1l
1fAM3 Drop Frame 398uud0ald cPU fillss@nsnaniinidon

NRAU Soft Ware 15U T1Jsunsy PhotoShop Faelumisanuadenin,  Tusunsy Lotus
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ScreenCam %30 lumstiufinmndunounis ¥y, Tisunsy Wave Studio $20lumstiufinuazan
Ao iy
6.2 uvaInalumanmnne
y ] [] » ¥

TuilegiiuiinisaadedoarsdiuInaifuszuvines (Stand Alone) uaviaiiuua Tduanuiion
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Source code ToolBook maﬂﬂsunsu

v A
** YU3G0 Project. TBK **

1 o/

- ** gaTUAdiedgnilade Project TBK **

L)

to handle enterbook

end

linkDLL "USER"
INT  lockWindowUpdate(WORD)
WORD getDeskTopWindow()
WORD findWindow(DWORD,string)
int showWindow(word,int)
end
linkDLL "TB50DOS.DLL"
string getcurrentdrive()
end linkDLL
linkDLL "TB50WIN.DLL"
int yieldApp()
end linkDLL
show viewer "Remote"
hide picture "ScmPlane" of background "U1,1,1"
system string ScmPath
system string ScmPathl
system string ScmPath2
system CheckBack
CheckBack =0
set ScmPath to getcurrentdrive()
g0 to page "TitlePage"

forward

50
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- *+ gaTUAlooonIAMTade Project TBK **

to handle leaveBook
unlinkDLL "USER"
unlinkDLL "TB50WIN.DLL"
forward

end

- ** aasUAsun19 115N Lotus ScreenCam 97 **

to handle ScmRun ScmFile
system ScmPath
system ScmPathl
system ScmPath2
ScmPathl = SemPath &":\Pro3P\SCREENCAM\"
run Scmpathl & "scplayer.exe /c/s/h/v80,60 " &ScmPath2 & ScmFile
get yieldapp(
get FindWindow(0,ScmFile & " - Lotus S::reenCam 97")
do
get yieldapp()
get FindWindow(0,ScmFile & " - Lotus ScreenCam 97")
until it=0

end ScmRun

o

- ** gn3UATHuAAS Transition #14 q Aufngiiiden **

to handle showWithTrans pObjList, pTrans
-- SHOW OBJECT LIST:
sysLockScreen = true
while (pObjList is not NULL)
pop pObjList
show it

end while

51
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-- RESET sysLockScreen, EAT PAINTING:
get LockWindowUpdate(sysClienthandle)
sysLockScreen = faise
get lockWindowUpdate(0)
sysSuspendMessages = true

-- TRANSITION TO THIS PAGE:
transition pTrans to this page

end showWithTrans

- ** ga3Ua IRenBnnIsUEAl Transition A1 9 Auingiidon +*

to handle hideWithTrans pObjList, pTrans
-- SHOW OBJECT LIST:
sysLockScreen = true
while (pObjList is not NULL)
pop pObjList
hide it
end while
-- RESET sysLockScreen, EAT PAINTING:
get LockWindowUpdate(sysClienthandle)
sysLockScreen = false
get lockWindowUpdate(0)
sysSuspendMessages = true
-- TRANSITION TO THIS PAGE:
transition pTrans to this page

end hideWithTrans

** y1i1 TitlePage **

a 1d 4 '
-+ gasUa IS uaumas Music **

to handle Firstldle
if syslevel = reader then

mmopen clip "music”
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mmPlay clip "music" notify self
mmPlay clip "speak” notify self
end

end

— ﬁﬂ?ﬂa‘nﬂﬂl‘l’l"liiﬁﬁ‘l Titlepage **

to handle enterpage
if syslevel = reader then
mmPlay clip "speak” notify self
end

end

-+ aa3UA 1 uING Music aRBAIIAT **

to handle mmNotify clipName, commandName, result
if clipName = clip "Music" and result contains "successful”
mmplay clip "Music" notify self
end if
if clipName = clip "speak" and result contains "successful”
send next in viewer "main"
end if

end

P - 9 .
—- ** gA3UAINo0oN9 N1 Titlepage **

to handle leavePage
mmclose "waveaudio"
mmyield

end leavePage

** Y91 Unitl **

— = gasUddledigui Unitl
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to handle EnterPage
if syslevel = reader then
get ASYM_Wait(3000,0)
ifit=0
send next in viewer "main"
end
end if

end

54

** M 1,1,1 **

— = gasUadiodiguin 1,1,1 **

-

to handle enterpage
if syslevel = reader then
mmPlay clip "speakl,1,1" notify self
objTracker = field id 256
send showWithTrans objTracker, "dissolve fast"
mmPlay clip "database" in Stage id 253 of Page "1,1,1" autoclose
mmPlay clip "video" in Stage id 255 of Page "1,1,1" autoclose
end if
forward

end

- ** AnTUARTAOLINGY Speakl,],1 TR AL IR I TantTron 1y, =

to handle mmNotify clipName, commandName, result
if clipName = clip "speakl,1,1" and result contains "successful”
send next in viewer "main"
end if

end

e *+ gasUfiionsnninnill 1,1,1 **

to handle leavePage
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-~ own mE

hide field id 256 '
mmclose "waveaudio”
mmyield

end leavePage

11,12 **

a 1 A 3
— * gadiadiodhguin 1,1,2 **

to handle enterpage

system ScmPath2

ScmPath2 = "e:\pro3P\screencam\"

if Syslevel = reader then
send showWithiTrans field "2 level", "dissolve fast"
send showWithTrans field id 323, "Blinds fast"
mmplay clip "Author" notify self

end

end

- *+ aasUanstvaeunaziau TUsINTY Lotus ScreenCam 97 nould lufantidaly »+

to handle mmNotify clipName, commandName, result

if clipName = clip "Author" and result = "successful" then
show field "loading" of this page
send ScmRun "Author.scm"
hide field "loading" of this page
mmplay clip "Reader” notify self

end

if clipName = clip "Reader” and result = "successful” then
show field "loading" of this page
send ScmRun "Reader.scm”
hide field "loading” of this page
send next in viewer "main"

end

end
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— *+ gasUAlooan NN 1,1,2 **

to handle leavepage
hide field"2 level"
hide field id 323
mmclose "waveaudio”

mmyield

\
end

** M11,1,3 **

rN & ] Y
— = aaTdddiadiguin 1,1,3 +»

to handle EnterPage
if Syslevel = reader then
mmopen clip "Ulpl,1,1" wait
send showWithTrans field id 259, "dissolve fast"
mmplay clip "Ulpl,1,1" notify self
end if
END

-+ ASUAATIVABUIRASUTAL Transition A1 9 AeullUFimidaly ==

to handle mmNotify clipName, commandName, result
if clipName = clip "Ulpl,1,1" and result = "successful" then

hide field id 259
send showWithTrans field "TextObject", "dissolve fast"
mmplay clip "object" notify self
get lockWindewUpdate(sysClientHandle)
show irregularpolygon "linel"
show group "object"”
show group "graphicsign"
get lockWindowUpdate(0)

--Suspend messages to prevent infinite loop
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sysSuspendMessages = true

transition "Blinds fast" to this page

if clipName = clip "object" arid result = "successful” then

end

hide field "TextObject"
send showWithTrans field "TextGroup", "dissolve fast"

mmplay clip "group" notify self

if clipName = clip "group" and result = "successful” then

end

hide field "TextGroup"

send showWithTrans field "TextPage", "dissolve fast"
mmplay clip "page" notify self

get lockWindowUpdate(sysClientHandle)

show irregularpolygon "line2"

show group "page"

show group "pagesign"

get lockWindowUpdate(0)

--Suspend messages to prevent infinite loop
sysSuspendMessages = true

transition "Blinds fast" to this page

if clipName = clip "page" and result = "successful" then

end

hide field "TextPage"

send showWithTrans field "TextBackground", "dissolve fast"
mmplay clip "background" notify self

get lockWindowUpdate(sysClientHandle)

show irregularpolygon "line3"

show group "background”

show group "backgroundsign"

get lockWindowUpdate(0)

--Suspend messages’to prevent infinite loop
sysSuspendMessa/ges = true

transition "Bl,inﬁs fast” to this page
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if clipName = clip "background" and result = "successful” then

end

hide field "TextBackground"

send showWithTrans field *TextBook", "dissolve fast"
mmplay clip "book" notify self

get lockWindowUpdate(sysClientHandle)

show irregularbolygén "line4"

show group "book"

show group "booksign"

get lockWindowUpdate(0)

--Suspend messages to prevent infinite loop
sysSuspendMessages = true

transition "Blinds fast" to this page

if clipName = clip "book" and result = "successful" then

end

hide field "TextBook"

send showWithTrans field "TextSystembook", "dissolve fast"
mmplay clip "systembook" notify self

get lockWindowUpdate(sysClientHandle)
show irregularpolygon "line5"

show irregularpolygon "lineLast"

show group "systembook"

show group "systembooksign"

get lockWindowUpdate(0)

--Suspend messages to prevent infinite loop
sysSuspendMessages = true

transition "Blinds fast" to this page

if clipName = clip "systembook" and result = "successful" then

end

pause 1 seconds

send next in viewer "main"
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to handle leavepage

end

mmclose "waveaudio”

mmyield

hide field "TextObject"

hide field "TextGroup"

hide field "TextPage"

hide field "TextBackground"
hide field "TextBook"

hide field "TextSystembook”
hide field id 259

hide irregularpolygon "linel"
hide irregularpolygon "line2"
hide irregularpolygon "line3"
hide irregularpolygon "line4"
hide irregularpolygon "line5"

hide irregularpolygon "lineLast"

hide group "object"

hide group "page"

hide group "background"
hide group "book"

hide group "systembook"
hide group "ToolbookII"
hide group "graphicsign"
hide group "pagesign”

hide group "backgroundsign"
hide group "booksign”

hide gréup "toolbooksign"
hide group "systembéoksign"

59



WM e oM mem ol

LN S S

-~ -
-t e ]

e

60

** ¥11,1,4 **

LI

aie 4
— = gandadiedigmii 1,14

9

TO HANDLE EnterPage
if Syslevel = reader then

send showWithTrans field id 94, "dissolve fast"
mmplay clip "Interface Element” notify self
get lockWindowUpdate(sysClientHandle)
show group id 90

show group id 91

show field id 73

show group id 92

show group id 93

get lockWindowUpdate(0)

--Suspend messages to prevent infinite loop
sysSuspendMessages = true

transition "dissolve fast" to this page

end if
END

- ** g4ATUAASI9ADY Clip Interface Element T1dmauan i lufanihdaly =

to handle mmNotify clipName, commandName, result

if clipName = clip "Interface Element" and result = "successful" then
send next in viewer "Main"
end

END
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— *+ gasUfiioeonninuT 1,1,4 **

—

to handle leavepage
hide group id 90
hide group id 91
hide field id 73
hide group id 92
hide group id 93
hide field id 94
mmclose "waveaudio"”
mmyield

end

LA RRARRERNERERENRRENDRRENENENENNERREYRENEERREERER AR RENERNNERRERNRERRERRERERNETE N

** M1,1,5 **

— ** gasUadodign 1,15 **

to handle enterpage

paude 1 seconds

if syslevel = reader then
send showWithTrans field "Tool Palette”, "dissolve fast"
mmPlay clip "Tool Palette" notify self
send showWithTrans group "Tool" , "dissolve fast"

end if

forward

end

- ** gASUAATINADULAZIAAL Transition A1 9 nouli ludamthdaly ==

to handle mmNotify clipName, commandName, result
if clipName = clip "Tool Palette" and result contains "successful”
hide field "Tool Palette"
send showWithTrans field "Pattern Palette”, "dissolve fast"

mmPlay clip "Pattern Palette” notify self
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send showWithTrans group "Pattem"” , "dissolve fast"

end

\

if clipName = clip "Pattern Palette" and result contains "successful"
hide field "Pattern Palette”
send showWithTrans field"line Palette”, "dissolve fast”
mmPlay clip "Line Palette" notify self
send showWithTrans group "Line" , "dissolve fast”
end
if clipName = clip "Line Palette" and result contains "successful"
hide field "Line Palette"
send showWithTrans field"Line End", "dissolve fast"
mmPlay clip "Line End" notify self
send showWithTrans group "Line End" , "dissolve fast"
end
if clipName = clip "Line End" and result contains "successful”
hide field "Line End"
send showWithTrans field"Polygon Palette", "dissolve fast"
mmPlay clip "Polygon Palette" notify self
send showWithTrans group "Polygon"” , "dissolve fast"
end
if clipName = clip "Polygon Palette" and result contains "successful”
hide field "Polygon Palette"
send showWithTrans field"Color Palette"”, "dissolve fast"
mmPlay clip "Color Palette" notify self
send showWithTrans group "color" , "dissolve fast"
end
if clipName = clip "color Palette" and result contains "successful"

send next in viewer "main"

~ end if

end

a e 4
—- = gaSUAlononvInni 1,1,5 **

to handle leavePage
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hide field "Tool Palette"
hide field "Pattern Palette"
hide field "Line Palette"
hide field "Line End"
hide field "Polygon Palette"
hide field "color Palette"
hide group "Tool"
hide group "Pattern"
hide group "Line"
hide group "Line End"
hide group "Polygon"
hide group "Color"
mmclose "waveaudio”
mmyield

end leavePage
(AR SRR AR EREREEREEREAAERRRRRRREENRENENRELAREANNNENNNEARNERERNENREEERNENNRNERERERENRRERDNJ] R

% Y11 Unit2 **

SRR EEE NN EANNNEEEEENNEA NN ENNENAEEEEESNDNNNNEE XN SEENARERANARSEERNEERS!
to handle EnterPage
if syslevel = reader then
get ASYM_Wait(3000,0)
ifit=0
send next in viewer "main”
end

end if

end

o+ 11 2,1,1 **

(AN EEEERRERERNSRAERREEREYEENESRRENERENERERERERSENENENNENNEEREERENNRERNNERNNNERRERRNRHENSNH}I

a A )
-+ gaSURilBthgmiT2,1,1 **

TO HANDLE EnterPage
if Syslevel = reader then

mmopen clip "Toolpalette” wait
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send showWithTrans field "ToolpaletteField", "dissolve fast"
mmplay clip "Toolpalette" notify self

end if

" END

e *+ qASUANTIVABUIAZUAAY Transition A2 q neul luFamihda’ly »+

to handle mmNotify clipName, commandName, result
in viewer "Main"
if clipName = clip "Toolpalette" and result = "successful” then
hide field "ToolPaletteField"
send showWithTrans field "Group1Field", "dissolve fast"
send showWithTrans Group "G1Field", "dissolve fast"
show Rectangle "B1"
mmplay clip "Groupl" notify self
end
if clipName = clip "Group1" and result = "successful" then
hide field "Group1Field"
send showWithTrans field "Group2Field", "dissolve fast"
send showWithTrans Groui) "G2Field", "dissolve fast"
mmplay clip "Group2" notify self
end
if clipName = clip "Group2" and result = "successful” then
) hide field "Group2Field"
send showWithTrans field "Group3Field", "dissolve fast"
send showWithrahs Group "G3Field", "dissolve fast"
show Rectangle "B13"
mmplay clip "Group3" notify self
end
if clipName = clip "Group3" and result = "successful" then
hide field "Group3Field"
send showWithTrans field "Group4Field", "dissolve fast"
send showWithTrans Group "G4Field", "dissolve fast"
mmplay clip "Group4" notify self
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end
if clipName = clip "Group4" and result = "successful" then
hide field "Group4Field"
send showWithTrans field "Group5Field", "dissolve fast”
send showWithTrans Group "G5Field", "dissolve fast”
show Rectangle "B25"
mmplay clip "Group5" notify self
end
if clipName = clip "Group5" and result = "successful” then
hide field "Group5Field"
send showWithTrans field "Group6Field", "dissolve fast"
send showWithTrans Group "G6Field", "dissolve fast"
show Rectangle "B2"
mmplay cfip "Group6” notify self
end
if clipName = clip "Group6" and result = "successful" then
hide field "Group6Field"
send showWithTrans field "Group7Field", "dissolve fast”
send showWithTrans Group "G7Field", "dissolve fast"
mmplay clip "Group7" notify self
end
if clipName = clip "Group7" and result = "successful" then
hide field "Group7Field"
send showWithTrans field "Group8Field", "dissolve fast"
send showWithTrans Group "G8Field", "dissolve fast"
show Rectangle "B14"
mmplay clip "Group8" notify self
end
if clipName = clip "Group8" and result = "successful" then
pause 1 seconds
send next in viewer "main"
end
end

end
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— ** gasUfiiioeanaInn 2,1,1 **

to handle leavepage
mmclose "waveaudio”
mmyield
hide field "ToolpaletteField"
hide field "Group1Field"
hide field "Group2Field"
hide field "Group3Field"
hide field "Group4Field"
hide field "Group5Field"
hide field "Group6Field"
hide field "Group7Field"
hide field "Group8Fieid"
hide Rectangle "BI"
hide Rectangle "B1"
hide Rectangle "B2"
hide Rectangle "B3"
hide Rectangle "B4"
hide Rectangle "B5"
hide Rectangle "B6"
hide Rectangle "B7"
hide Rectangle "B8"
hide Rectangle "B9"
hide Rectangle "B10"
hide Rectangle "B11"
hide Rettangle "B12"
hide Rectangle "B13"
hide Rectangle "B14"
hide Rectangle "B15"
hide Rectangle "B16"
hide Rectangle "B17"
hide Rectangle "B18"
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hide Rectangle "B19"
hide Rectangle "B20"
hide Rectangle "B21"
hide Rectangle "B22"
hide Rectangle "B23"
hide Rectangle "B24"
hide Rectangle "B25"
hide group "G1Field"
hide group "G2Field"
hide group "G3Field"
hide group "G4Field"
hide group "G5Field"
hide group "G6Field"
hide group "G7Field"
hide group "G8Field"

end

12,12 **

— = ansUadediguin 2,1,2 **

TO HANDLE EnterPage
if Syslevel = reader then
mmopen clip "ButtonNormal" wait
send showWithTrans field "NormalField", "dissolve fast"
mmplay clip "ButtonNormal" notify self
end if
END ™

- ** A3UAATIVEBLIALIARS Transition a1 9 Aould ldamrdaly *+

to handle mmNotify clipName, commandName, result
if clipName = clip "ButtonNormal" and result = "successful" then
send showWithTrans field "InvertField", "dissolve fast"

mmplay clip "ButtonInvert" notify self
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end

end

if clipName = clip "ButtonInvert"” and result = "successful” then
send showWithTrans field "DisabledField", "dissolve fast"
mmplay clip "ButtonDisable" notify self

end

if clipName = clip "ButtonDisable" and result = "successful" then.
send showWithTrans field "CheckedField", "dissolve fast"
mmplay clip "ButtonCheck" notify self

end

if clipName = clip "ButtonCheck" and result = "successful" then
do

get ASYM_Wait(3000,0)

until it=0 -- If key or mouse pressed it = 255
send next in viewer "main"

end

a e A 9
- gA3UAIIBDDNINNNT 2,1,2 **

to handle leavepage

end

mmclose "waveaudio”
mmyield

hide field "NormalField"
hide field "InvertField"
hide field "DisabledField"
hide field"'CheckedField"

*x Y1112,1,3 **

! 3/

a (¢ A 3
- #x gasdallongniin 2,1,3 **

Y

to handle enterpage

system ScmPath2
system ScmPath
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ScmPath2 = Scmpath &":\pro3P\screencam\Unit2\"
show picture "ScmPlane” of this background

send AutoRun

flag=1

end

TN TA o v
- *+ gaTUanugUMITIULLUBA WA **

to handle AutoRun
if Syslevel = reader then
get ASYM_Wait(4000,0)
ifit=0
 show field "loading” of this background
send ScmRun "PushButton.scm"
hide field "loading” of this background
end
if keyState(keyLeftButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading” of this background
send ScmRun "PushButtonScript.scm"
hide field "loading" of this background
end
if keyState(keyLeftButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading” of this background
send ScmRun "PushButtonExam.scm”
hide field "loading" of this background

end
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get ASYM_Wait(5000,0)
ifit=0

send next in viewer "main"
end

end

end

>

- *+ A UARURUMTHOUAILA B **

to handle buttonclick

system flag

if target is button id 74
show field "loading" of this background

1 send ScmRun "PushButton.scm”

hide field "loading" of this background
flag=0

else

if target is hotword id 78
show field "loading" of this background
send ScmRun "PushButtonScript.scm”

hide field "loading" of this background

flag=0

else

if targetis hotword id 82
show field "loading" of this background
send ScmRun "PushButtonExam.scm”
hide field "loading" of this background
flag=0

else

if target is button "checkAUTO" and flag < 1
send AutoRun
flag=1

else

flag=0

70



g

- e v we

71

end; end; end; end

end

— == gasUdiliooonanuYn 2,1,3 **

to handle leavepage

hide picture "ScmPlane" of this background
hide field "loading" of this background
mmeclose "waveaudio”

mmyield

end

M 2,1,4 **

- #+ aasUalodiguii 2,14 #*

<

to handle enterpage
system ScmPath2

system ScmPath
ScmPath2 = Sempath &":\pro3P\screencam\Unit2\"

show picture "ScmPlane" of this background
send AutoRun
flag=1

end

a gd Y wa
- gATUANIUAUMSTOUUUUDR TUNR **

to handle AutoRun
if Syslevel = reader then
get ASYM_Wait(4000,0)
ifit=0
show field "loading” of this background
send ScmRun "Line.scm”

hide field "loading" of this background

end
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if keyStaté(keyLeftButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background
send SecmRun "Arc.scm"
hide field "loading" of this background
end
if keyState(keyLeﬁBution) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background
.send ScmRun "AngledLine.scm"
hide field "loading" of this background
end
if keyState(keyLeftButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
show, field "loading" of this background
send ScmRun "Curve.scm"
hide field "loading" of this background
end
if keyStaté(keyLeftButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background

send ScmRun "Rectangle.scm"
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hide field "loading” of this background
end
if keyState(keyLefiButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background
send ScmRun "RoundedRectangle.scm"
hide field "loading" of this background
end ‘
if keyState(keyLeftButton) is "down'.'
break
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background
send eScm“Run "Ellipse.scm"”
hide field "loading" of this background
end
if keyState(keyLeftButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background
send ScmRun "RegularPolygon.scm”
hide field "loading" of this background
end
if keyState(keyLeftButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
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show field "loading” of this background
send ScmRun "IrregularPolygon.scm"
hide field "loading” of this background
end
if keyState(keyLeftButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
shiow field "loading” of this background
send ScmRun "Pie.scm”
hide field "loading" of this background
end
get ASYM_Wait(5000,0)
ifit=0
send next in viewer "main"
end
end

end

— = gasUAnIuguNTIONAIA ey **

~
~

to handle buttonclick

system flag

if target is button id-25
show field "loading" of this background
send ScmRun "Line.scm"
hide field "loading" of this background
flag=0

else

if target is button id 26
show field "loading" of this background
send SemRun "Arc.scm"

hide field "loading" of this background
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flag=0

else

if target is button id 27
show field "loading" of this background
send ScmRun "AngledLine.scm"
hide field "loading" of this background
flag=0

else

if target is button id 28
show field "loading" of this background
send ScmRun "Curve.scm"

hide field "loading" of this background

flag=10

else

if target is button id 29
show field "loading" of this background
send ScmRun "Rectangle.scm”
hide field "loading" of this background
flag=0

else

if target is button id 30
show field "loading" of this background
send ScmRun "RoundedRectangle.scm”
hide field "loading" of this background
flag=0

else

if target is button id 31
... showiield "loading" of this background
send ScmRun "Ellipse.scm"
hide field "loading" of this background
flag=0
else
if target is button id 32

show field "loading" of this background

75



e

-

L o A

e

76

send ScmRun "RegularPolygon.scm”
hide field "loading" of this bz{ckground

flag=0

else

if target is button id 33
show field "loading" of this background
send ScmRun "Irregularpolygon.scm"
hide field "loading" of this background
flag=0

else

if target is button id 34
show field "loading" of this background
send ScmRun "Pie.scm"
hide field "loading" of this background
flag=0

else

if target is button "checkAUTO" and flag <> 1
send AutoRun
flag=1
else
flag=0
end; end; end; end; end; end; end; end; end; end; end

end

—- *+ aaSUdilonsnainuril 2,1,4 **

¢

to handle leavepage
hide picture."ScmPlane" of this background
hide field "loading" of this background
mmclose "waveaudio"
mmyield

end
Il-IIIII.IIIIIIII.IIIIIIIIIIIIIIIllllIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII'

** 111 2,1,5 **
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to handle enterpage
system ScmPath2
system ScmPath
ScmPath2 = ScmPath &":\pro3P\screencam\Unit2\"
show picture "ScmPlane" of this background
send AutoRun
flag=1

end

- #+ gasUARIURUMIEOULLLDA TUliA **

to handle AutoRun
if Syslevel = reader then
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background
send ScmRun "Field.scm”
hide field "loading" of this background
end
if keyState(keyLeftButton) is "down"
break
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background
- send Sclyliun "RecordField.scm"
hide field "loading" of this background
end
if keyState(keyLeftButton) is "down" ‘
break

end
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get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background
send ScmRun "BorderlessField.scm"
hide field "loading" of this background
end
if keyState(keyLeftButton) is "down"
break
end
‘get ASYM_Wait(4000,0)
ifit=0
show field "loading” of this background
send ScmRun "ListboxField.scm"
hide field "loading" of this background
end
get ASYM_Wait(5000,0)
ifit=0
send next in viewer "main”
end
end

end

- ** gAsUARIUANMITOURIBAINDY **

to handle buttonclick

system flag

iftarget is buttorrid 28
show field "loading” of this background
send ScmRun "Field.scm"”
hide field "loading" of this backgrou.nd
flag=0

else

if target is button id 29

show field "loading" of this background
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end

send ScmRun "RecordField.scm"

hide field "loading" of this background

flag=0

else

if target is button id 30
show field "loading" of this background
send ScmRun "BorderlessField.scm”
hide field "loading" of this background
flag=10

else \

if target is button id 31
show field "loading" of this background
send ScmRun "ListboxField.scm"
hide field "loading” of this background
flag=0

else

if target is button "checkAUTO" and flag <> 1
send AutoRun
flag=1

else

flag=0

end; end; end; end; end

— * gAsUfidiosoninnin 2,1,5 **

to handle leavepage

end

hide picture "ScmPlane" of this background
hide field "loading" of this background
mmclose "waveaudio”

mmyield
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** W1 Unit3 **

- ** gaTUAiod gl Unis **

to handle EnterPage

if syslevel = reader then

.

o T

get ASYM_Wait(3000,0)
ifit=0

send next in viewer "main"

end
end if
end
RE S EE S RN ER O ES S N EEE I EEEN RSN NS A DS I A E R AN R EN N AN IR RN NN RN EE N AN AN R SRR
** uP13,1,1 ** ’

a & 1
— ++ anSufudiadignin 3,1,1 **

to handle enterpage
system ScmPath2
system ScmPath
ScmPath2 = ScmPath &":\pro3P\screencam\Unit3\"
show picture "ScmPlane" of this background f
send AutoRun
flag=1

end

a (e . o i
— ** gasUanIugUMsAOULULSATUTRA **

to handle AutOR’l\.lE
if Syslevel = reader then
get ASYM_Wait(2000,0)
ifit=0
show field "loading" of this background
send ScmRun "MakeSound.scm"
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hide field "loading" of this background
end
get ASYM_Wait(2000,0)
ifit=0
show field "loading" of this background
send ScmRun "PlaySound.scm”
hide field "loading" of this background
end
get ASYM_Wait(5000,0)
ifit=0
send next in viewer "main"
end
end

end

— *+ aa3UARINgUMIADOUAITA BT **

to handle buttonclick
system flag
if target is hotword id 14
show field "loading"” of this background
send ScmRun "Makesound.scm"
hide field "loading" of this background
flag=0 .
else
if target is hotword id 12
show field "loading" of this background
send ScmRun "Playsound.scm”
hide field "loadirig" of this background
flag=0 )
else
if target is button *checkAUTO" and flag < 1

send AutoRun

flag=1
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else
flag=0
end; end; end

end

e % gnSUAIERENTINNIT 31,1 **

to handle leavepage
hide picture "ScmPlane" of this background
hide field "loading" of this background
mmclose "waveaudio”
mmyield

end

** W013,12 **

-+ gasUnudiodiguin 3,12 =

to handle enterpage
system ScmPath2
system ScmPath
ScmPath2 = ScmPath &":\pro3P\screencam\Unit3\"
show picture "ScmPlane" of this background
send AutoRun
flag=1

end

ey
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to handle AutoRun
if Syslevel = reader then
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of this background
send ScmRun "MakeVideo.scni™
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hide field "loading" of this background
end
get ASYM_Wait(4000,0)
ifit=0
show field "loading" of thjs background
send ScmRun "PlayVideo.scm"
hide field "loading" of this background
end
get ASYM_Wait(5000,0)
ifit=0
send next in viewer "main"
end
end

end

— ** gAsUAnILRUMITOUAIIAIDY **

to handle buttonclick-
system flag
if target is hotword id 21
show field "loading" of this background
send ScmRun "MakeVideo.scm"
hide field "loading” of this background
flag=0
else
if target is hotword id 15
show field "loading" of this background
send ScmRun "PlayVideo.scm"
hide field "loading" of this background
flag=0
else
if target is button "check AUTO" and flag < 1
send AutoRun

flag=1
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else

flag=0

end; end; end

end

—— = aasUdAdipoanainni 3,12 **

to handle leavepage
hide picture "ScmPlane" of this background
hide field "loading" of this background
mmclose "waveaudio"
mmyield

end

bl ‘Hﬁ"l Uanimation **
I RN R E R R EREREEEEEZERER AR R R ERERRERYRERRRRERRRRRRRERRRERRRRRRRRRERRERERERERRNEN

a (o A 9 1 9 9 “
- ** gasUallodgnil) Uanimation **

TO HANDLE Enterpage
if syslevel = reader then .
send playAnimation 1,this page,true to button id 43
send playAnimation 1,this page,true to button id 34
send playAnimation 1,this page,true to button id 44
send next in viewer "main"
end

END

a (¢ A s . .
- ** gAS1Ap80NINMII Uanimation **

to handle leavepage
send restoreAnimation button id 34
send restoreAnimation button id 43
send restoreAnimation button id 44

end
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WY 3,1,4 **
(A B SRR R EEEE B ER 2R R ERER R RR AR R ERE R R RRRERERRERERRERRRRRRRRRERRRRRRERE R

a2 A w
- *+ gnSUfuliedngmin 3,14 **

to handle enterpage
system ScmPath2
system ScmPath
ScmPath2 = ScmPath &":\pro3P\screencam\Unit3\"
show picture "ScmPlane" of this background
send AutoRun
flag=1

end

e+ gasUamuRUMTAOULLUER TUITR **

, tohandle AutoRun
if Syslevel = reader then

get ASYM_Wait(4000,0)

ifit=0
show field "loading" of this background
send ScmRun "TransitionScriptl.scm”
hide field "loading" of this background

end

get ASYM_Wait(4000,0)

ifit=0
show field "loading" of this background
send ScmRun "TransitionScript2.scm"
hide field "loading" of this background

end

get ASYM_Wait(5000,0)

ifit=0
send next in viewer "majn"

end

end
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end

- *+ gATUARILAUNMITOURILANDY **

to handle buttonclick

end

system flag

if target is hotword id 19
show field "loading" of this background
send ScmRun "TransitionScript]l.scm”
hide field "loading" of this background
flag=0

else

if target is hotword id 13
show field "loading" of this background
send ScmRun "TransitionScript2.scm"”
hide field "loading" of this background
flag=0

€lse

if targe?fs button "check AUTO" and flag <> 1
send AutoRun
flag=1

else
flag=0

end; end; end

-+ gpfifuilooonninnil1 3,14 *+

to handle leavepage

end

hide picture "ScmPlane" of this background
hide fi€ld "loading" of this background
mmclose "waveaudio”

mmyield
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*% Y113,1,5 **

- A '
-+ gasUmiodhgniin 3,15 *

L

to handle enterpage
system ScmPath2
system ScmPath
ScmPath2 = ScmPath &":\pro3P\screencam\Unit3\"
show picture "ScmPlane" of this background
send AutoRun
flag=1

end

- *+ gasUARURUAITABUNLLOA TUNA *=

to handle AutoRun
if Syslevel = reader then

get ASYM_Wait(4000,0)

ifit=0
show field "loading" of this background
send ScmRun "PathAnimation.scm”
hide field "loading" of this background

end

get ASYM_Wait(4000,0)

ifit=0
show field "loading" of this background
send ScmRun "PlayPathAnimation.scm"
hide field "loading" of this background

end

end

end

- = gATUAMIUAUMITBURILAUBY **
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to handle buttonclick

end

system flag

if target is hotword id 19
show field "loading" of this background
send ScmRun "PathAnimation.scm"
hide field "loading" of this background
flag=0

else

if target is hotword id 13
show field "loading" of this background
send ScmRun "PlayPathAnimation.scm"
hide field "loading" of this background
flag=0

else

if target is button "checkAUTO" and flag <> 1

send AutoRun
flag=1

else
flag=0

end; end; end

= gasUAIopDNIIANT 3,1,5 **

to handle leavepage

end

hide picture "ScmPlane" of this background
hide field "loadirig" of this background
mmclose "waveaudio"” _

mmyield
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** mfh Remote **
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— ** gn5UAdlonall Next 1Az Previous **
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to handle buttonClick
system CheckBack
CheckBack =0
in viewer "main"
get pagenumber of this page
end
in viewer "remote"
if target is button "Previous"
ifit< 1
CheckBack =1
send previous in viewer "Main"
Break
end
else
if target is button "Next"
ifit< 19
CheckBack =2
send next in viewer "Main"
Break
end
end; end; end

end buttonClick

-+ ga3dAiledeunndidngiy About **

to handle MouseEnter
syscursor = 44

end’

a A 4 C
- hE ﬁﬂiﬂémﬂlﬁﬁutﬁ’]ﬁ’ﬂaﬂﬂ]ﬂﬂﬁ About **

to handle MouseLeave

syscursor = default

end
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a 1¢ 4 1
— *+ gasUdilonaty About **

to handle buttonclick
mmclose all
mmyield
show viewer "about"

end

** 11{1 About **

19

e *% aasUAdBd NI About **

«

to handle enterpage
if syslevel = reader then

mmplay clip "About"

end; end

- = ansUAnTI9TeUINAY About Br9ulRiauinas Music ap **

to handle mmNotify clipName, commandName, result

if clipName = clip "about" and result contains "successful”
mmplay clip "Music" notify self

end if

if clipName =<clip "Music" and result contains "successful”
mmplay clip "Music" notify self
end if

end

—- ** gA51AIepNINMI About **

to handle leavepage
mmclose all
mmplay clip "Music" notify self

end
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